09 tsx droping rpm when start moving

FlashPro questions & answers specific to the 2007-2008 US TSX
Post Reply
wkl1993
Posts: 5
Joined: Thu Mar 03, 2022 9:05 pm

09 tsx droping rpm when start moving

Post by wkl1993 »

hi everyone.
im a noob on tuning. helping my friend to tune his car, cuz the tune before is really bad. after i get everything basic dialed in the car feels like it needs to rev higher to start moving or it will drop rpm bad, feels like it needs more torque. i try to play around with the lower end but it doesn't help.
see if you guys can give me some idea on improving this. i will be much appreciated.
thanks!


Mod:
12.5 comp piston
410cc injector
dc5 cam with rbc cam gear
skunk2 street manifold
ktuned 72mm tb
ktuned fuel rail
password intake
map based map

something i noticed:
cold start after rpm stable map shows -19.x psi when drive a bit it goes to -21.x sometime it will pop intake leak code but i unchecked it.
the ignition retard is bad.
the tune before runs really rich 10.34ish with stft -31, after drive ltft -22 stft-16.

anything you guys think let me know!
Attachments
09 tsx 410cc+cam baseline CL3.7.fpcal
(20.38 KiB) Downloaded 160 times
datalog0007.fpdl
(3.38 MiB) Downloaded 149 times
wkl1993
Posts: 5
Joined: Thu Mar 03, 2022 9:05 pm

Re: 09 tsx droping rpm when start moving

Post by wkl1993 »

i forgot to say he has k20 head so
EFICU
Posts: 3295
Joined: Mon Feb 25, 2019 10:14 pm

Re: 09 tsx droping rpm when start moving

Post by EFICU »

Did your friend check for piston to valve clearance when he was doing the cylinder head swap? 45* might be a little too much cam angle for that setup, but that's easy to change. If he did clay it and it was fine, then that works too, just want to make sure he doesn't have trouble with it.

Are you trying to tune the 0* cam angle right now on part throttle, or how did you determine your cam angle mapping? With it on the 0* cam angle, that will be the least powerful cam angle and could be part of the problem as to why it struggled to get off the line.

The best way to do it is to go in and tune each cam angle one by one. Starting with the 0* cam angle, you want to go in and tune those 0* cam angle tables in totality, then you can copy and past those 0* values into the 15* cam angle and tune that, then so on. It's difficult to tune all cam angles at once and really not possible because it's constantly changing cam angles.
wkl1993
Posts: 5
Joined: Thu Mar 03, 2022 9:05 pm

Re: 09 tsx droping rpm when start moving

Post by wkl1993 »

EFICU wrote: Sat Mar 05, 2022 5:28 pm Did your friend check for piston to valve clearance when he was doing the cylinder head swap? 45* might be a little too much cam angle for that setup, but that's easy to change. If he did clay it and it was fine, then that works too, just want to make sure he doesn't have trouble with it.

Are you trying to tune the 0* cam angle right now on part throttle, or how did you determine your cam angle mapping? With it on the 0* cam angle, that will be the least powerful cam angle and could be part of the problem as to why it struggled to get off the line.

The best way to do it is to go in and tune each cam angle one by one. Starting with the 0* cam angle, you want to go in and tune those 0* cam angle tables in totality, then you can copy and past those 0* values into the 15* cam angle and tune that, then so on. It's difficult to tune all cam angles at once and really not possible because it's constantly changing cam angles.
hi man!

his engine builder said the clearance was fine i was trying to put 40 which basically make the same power imo. just too be safe lol. but he did run 45 for a year and no problem. so i guess its fine.

yes like you said i was trying to tune the 0 degree first just make sure the car is good, and i have a base foundation. tbh i just realize the problem yesterday and put everything into the 15 degree and the car runs MUCH better. now im just need to finish the fuel and ignition and go for 30 just to get the map smooth out.

thank you very much for the opinion! that is really helpful!
Btw: tuning is fun lol, even there is straggle.
EFICU
Posts: 3295
Joined: Mon Feb 25, 2019 10:14 pm

Re: 09 tsx droping rpm when start moving

Post by EFICU »

Sounds good. Yeah it sounds like you're on the right track then. Get each cam angle dialed, then copy and past it into the next cam angle map and tune that. It's nice to have a template each time you move up in cam angle.

Good luck with it, hopefully you can get it dialed. Sounds like a fun setup.
wkl1993
Posts: 5
Joined: Thu Mar 03, 2022 9:05 pm

Re: 09 tsx droping rpm when start moving

Post by wkl1993 »

EFICU wrote: Mon Mar 07, 2022 7:45 pm Sounds good. Yeah it sounds like you're on the right track then. Get each cam angle dialed, then copy and past it into the next cam angle map and tune that. It's nice to have a template each time you move up in cam angle.

Good luck with it, hopefully you can get it dialed. Sounds like a fun setup.
just one more question, hope you dont mind.
im trying to fix all the ign retard on WOT. but no matter what i do it still showing retard. would that be come from the engine bay noise or something? it get wired knock count even when knock level is 30% ish, and it kind of random

he has the same problem on the old tune too.

hope you can give some hints.
EFICU
Posts: 3295
Joined: Mon Feb 25, 2019 10:14 pm

Re: 09 tsx droping rpm when start moving

Post by EFICU »

What is the knock control value on your WOT pulls?
Patilgk1999
Posts: 2
Joined: Thu May 28, 2020 5:11 pm

Re: 09 tsx droping rpm when start moving

Post by Patilgk1999 »

What header was used for this setup? I have done a lot of looking and there is next to nothing about headswap in the CU2 chassis. From crawling around my CU2 and CL9s I have found in junkyard it looks like a CL9 header may work but I'm not 100% sure.
Post Reply