Gears not sowing properly on datalogs.

FlashPro questions & answers specific to the 2010 CR-Z (US, Euro & Asia)
Post Reply
alollini
Posts: 58
Joined: Tue Dec 11, 2012 1:49 am

Gears not sowing properly on datalogs.

Post by alollini » Mon Aug 04, 2014 7:41 am

Hello,
I just changed on my 2010 CRZ the final drive. ( M-Factory 4.9 )

it looks like the flash pro record wrong gear number ; something like 1, 2, 3, 3, 4, 5

and it is sometimes hesitating to register the gear, it oscillate btw two different gears while in gear.

is this something we did wrong when re-assembling sensors ?

is this problem related to the IMA not regenerating on brakes or throttle release ?

(the IMA is still regenerating on light throttle)

please note that the speed displayed on the dash is still correct. (and different from VSS of flashpro)

I know this topic has been already discussed, but i try a different angle,
I know flashpro don't touch IMA.

If you need a specific datalog to investigate my case, please ask, I will make it as you specify.
Team CR-Z Youtube Videos here => http://www.youtube.com/playlist?list=PL127E8C02C6B25D4B&feature=plcp
CR-Z GT White "Blue Inside"

User avatar
Hondata
Site Admin
Posts: 8762
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: Gears not sowing properly on datalogs.

Post by Hondata » Mon Aug 04, 2014 7:52 am

Both the IMA and ECU calculate the gear by rpm / speed. Changing the final drive will change the relationship, and so the detected gear. I'm not sure why the speed on the cluster is not affected.
Hondata

alollini
Posts: 58
Joined: Tue Dec 11, 2012 1:49 am

Re: Gears not sowing properly on datalogs.

Post by alollini » Mon Aug 04, 2014 8:28 am

I have searched again in the books (for US version) that I have. (I have an EU vehicle - it has some differences, but transaxle is unlikely)
gearbox, differential, clutch : found no evidence.
there is just a reverse lock, witch sense speed, a reverse light swich, and a neutral swich.
in the IMA motor housing there is just a position sensor (would need elaborate calculation to determine speed)

My hypothesis is a VSA/ABS speed sensor (one on each wheel) may be used. (don't you use that in your traction control ??)

My friend who did the gearbox say there is a speed sensor somewhere on the final / differential / clutch that sense speed.


from FlashPro help :
Vehicle Speed Sensor

VSS is a measure of the vehicle ground speed, calculated from the VSS sensor, which is located on the transmission. Because the speed of the driven wheels is measured, wheel slip and wheel spin are not compensated for.
maybe irrelevant question : how does the cruise control work on this vehicle?
end-user small manual says it is some data taken from 3rd gear gear... (I think it is not)


are we screwed if it takes speed from IMA ?
Team CR-Z Youtube Videos here => http://www.youtube.com/playlist?list=PL127E8C02C6B25D4B&feature=plcp
CR-Z GT White "Blue Inside"

alollini
Posts: 58
Joined: Tue Dec 11, 2012 1:49 am

Re: Gears not sowing properly on datalogs.

Post by alollini » Wed Aug 06, 2014 10:36 pm

If we solve this calculated gear issue, I think that will de facto solve the ima issue.

I have tried Harry's lap timer and in that app I setup all the gears ratios, it now shows me correct gears.
Team CR-Z Youtube Videos here => http://www.youtube.com/playlist?list=PL127E8C02C6B25D4B&feature=plcp
CR-Z GT White "Blue Inside"

alollini
Posts: 58
Joined: Tue Dec 11, 2012 1:49 am

Re: Gears not sowing properly on datalogs.

Post by alollini » Wed Aug 13, 2014 2:18 am

Here is my conversation on the Harry's Lap Timer forum
about OBD queries and answers using GoPoint GL1 cable and also BT1A device with iphone 5c and the app wich can send xml datalogs by email.

(I have one xml datalog available if you wish to take a look I can send by email)
Harry wrote:The dialog seen in the log is o.k. The special thing about your car is there seem to be three ECUs responding to most requests (which is unusual). Sometimes the ECUs answer with different results (e.g. asking for speed generates 3 replies with 2 different values), which generates small jumps depending on the reply timing. That is nothing that can be improved with the current version but I will add an OBD Tweak to an upcoming version that allows filtering replies to one ECU only.

- Harry



I changed the final gear and as mechanically it works perfectly fine, this modification upsets some data in the electronics, leading to gear not reporting correctly and ultimate results maybe :
- inconsistencies in Lap Timer (rpm jumpy - poor frame rate in odb return info)
- hybrid system of the car does not want to do the regenerative braking part.


when the BT1A queries the car, it gets 3 modules answers ?

- one should be the PGMFI i can work on with Flashpro (there is a speed "VSS" correction here i can edit)

- a second one should be IPU (intelligent power unit = linked to the hybrid IMA battery pack) maybe i can watch its behavior with my HDS : the equippment of Honda dealership i have. (witch i don't know how to use)

- the third i have no idea ?

that would be great if we could make progress on this as there is one cause, several consequences, and mutual interests in those issues.

any more information would be greatly appreciated.
Harry wrote:Hi,

The VSS request is answered with

00 03 03 41 0D 11
00 04 03 41 0D 11
00 10 03 41 0D 11

0x03 / 0x04 / 0x10 are the ECUs answering and they look pretty custom. I know there is a mode 0x09 pid 0x0a which returns a 20 byte ECU name but I do not know if your car / ECUs support this PID. Furthermore, LapTimer does not query this PID, so is of little help here. You may try some OBD dedicated software to check that. As the GoPoint OBDs use a binary protocol, a terminal window I would use for ELM327 dongles cannot be used.

The engine / main ECU will typically be 0xE8 with other "standard" ECUs some where above... The transmission ECU will typically use 0xE9.

- Harry
as i understand if laptimer app shows right gears it is because calculation is made inside the iphone app,
that would be great if we could bring the rigt calculation/data to the actual car, so that it works.
Team CR-Z Youtube Videos here => http://www.youtube.com/playlist?list=PL127E8C02C6B25D4B&feature=plcp
CR-Z GT White "Blue Inside"

Post Reply