ERROR:Daughter board communication When cranking voltage low

K-Series Programmable ECU installation questions / support issues
Post Reply
EGK2082
Posts: 18
Joined: Mon May 05, 2014 2:45 pm

ERROR:Daughter board communication When cranking voltage low

Post by EGK2082 » Mon May 05, 2014 3:28 pm

eg/k20z3, I have the following error: Daughter board communication When cranking voltage low, ground perfect, new battery oem location. charging 14v, drops to 12v and misfire in the blink of an eye, and becomes perfect to 14v

User avatar
Spunkster
Site Admin
Posts: 17744
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: ERROR:Daughter board communication When cranking voltage

Post by Spunkster » Mon May 05, 2014 4:32 pm

Is the battery in the OEM location for an EG, or OEM for a K20?

EGK2082
Posts: 18
Joined: Mon May 05, 2014 2:45 pm

Re: ERROR:Daughter board communication When cranking voltage

Post by EGK2082 » Tue May 06, 2014 1:15 pm

Spunkster wrote:Is the battery in the OEM location for an EG, or OEM for a K20?

OEM location for an EG

User avatar
Hondata
Site Admin
Posts: 8686
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: ERROR:Daughter board communication When cranking voltage

Post by Hondata » Tue May 06, 2014 1:59 pm

EGK2082 wrote:drops to 12v and misfire in the blink of an eye, and becomes perfect to 14v
With the engine running, or when cranking?

What does the voltage drop to when cranking? Can you make a datalog?
Hondata

User avatar
Spunkster
Site Admin
Posts: 17744
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: ERROR:Daughter board communication When cranking voltage

Post by Spunkster » Tue May 06, 2014 2:08 pm

Have you measured the voltage with a multimeter at the ECU when you are cranking and get this error?

EGK2082
Posts: 18
Joined: Mon May 05, 2014 2:45 pm

Re: ERROR:Daughter board communication When cranking voltage

Post by EGK2082 » Tue May 06, 2014 3:16 pm

Hondata wrote:
EGK2082 wrote:drops to 12v and misfire in the blink of an eye, and becomes perfect to 14v
With the engine running, or when cranking?

What does the voltage drop to when cranking? Can you make a datalog?

happens with the engine running
I'll make a datalog

User avatar
Hondata
Site Admin
Posts: 8686
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: ERROR:Daughter board communication When cranking voltage

Post by Hondata » Wed May 07, 2014 6:30 am

Best to use a multimeter on the ECU pins (A2 & A4) when cranking. Be very careful not to short anything out.
Hondata

The Spectacle
Posts: 95
Joined: Wed Jul 15, 2009 11:09 am

Re: ERROR:Daughter board communication When cranking voltage

Post by The Spectacle » Fri May 09, 2014 11:54 am

I've had this same error/problem recently. The ECU would throw the code immediately after the motor started. I had a friend check over everything and I had a bad ground at the battery. We fixed the ground and the problem hasn't returned. I would start there and get a second opinion on it from someone good with wiring to make sure that's not the problem.

EGK2082
Posts: 18
Joined: Mon May 05, 2014 2:45 pm

Re: ERROR:Daughter board communication When cranking voltage

Post by EGK2082 » Wed May 14, 2014 2:15 pm

Problem solved, one of the ground wire, had not had good ground, had painting.

User avatar
Hondata
Site Admin
Posts: 8686
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: ERROR:Daughter board communication When cranking voltage

Post by Hondata » Wed May 14, 2014 2:38 pm

Glad it is fixed and thanks for posting the solution.
Hondata

EGK2082
Posts: 18
Joined: Mon May 05, 2014 2:45 pm

Re: ERROR:Daughter board communication When cranking voltage

Post by EGK2082 » Sat May 17, 2014 10:38 am

Hondata wrote:Glad it is fixed and thanks for posting the solution.

Thank you for helping me.

perspective
Posts: 22
Joined: Mon Oct 21, 2013 1:50 pm

Re: ERROR:Daughter board communication When cranking voltage

Post by perspective » Wed Jun 11, 2014 2:06 pm

I had the same issue, I replaced the ground on the battery never had any problems after that.
Also , if you turn the key to on , wait for the fuel pump to prime and the kpro clicks, then turn the engine,
this trick helps to get less check engine lights while you figure what is caussing it

Post Reply