car stalls after fill up ep3

K-Series Programmable ECU installation questions / support issues
Post Reply
perspective
Posts: 22
Joined: Mon Oct 21, 2013 1:50 pm

car stalls after fill up ep3

Post by perspective » Fri Feb 28, 2014 12:31 pm

Everytime I put gas my car won't hold the revs(civic si 04). To keep it from stalling I press the pedal constantly . After 2-3 minutes of this issue it stops , and it goes back to normal until the next fill up.
It started doing this since the kpro was installed. I know other ep3s with this problem, which started also after installing the kpro.

Anybody can help me with this !!?

User avatar
Spunkster
Site Admin
Posts: 17772
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: car stalls after fill up ep3

Post by Spunkster » Fri Feb 28, 2014 2:25 pm


turbosi05
Posts: 4
Joined: Thu Dec 25, 2008 7:40 am

Re: car stalls after fill up ep3

Post by turbosi05 » Sat Mar 01, 2014 2:50 pm

Think it has to do with the purge solenoid staying open. . Unplugged mine and it stopped

perspective
Posts: 22
Joined: Mon Oct 21, 2013 1:50 pm

Re: car stalls after fill up ep3

Post by perspective » Wed Mar 05, 2014 3:59 pm

turbosi05 wrote:Think it has to do with the purge solenoid staying open. . Unplugged mine and it stopped
When you say unplugged, you mean removing it from the tb and leaving it connected to the hose? Did you disable it with kpro (Purge system disabled)??
Or removed solenoid and left/plugged the hose that was attached to solenoid?

cukali
Posts: 37
Joined: Thu Apr 27, 2006 10:48 am

Re: car stalls after fill up ep3

Post by cukali » Tue Mar 11, 2014 7:44 am

Dont disable itr in Kpro. If stuck open that wont help. If your not going to replace it (which I would do), then unplug it from the throttle body and plug BOTH the purge hose and throttle vacumm fitting. You can also leave it on the engine but unplug the line from the tank and put a plug AND clamp for security.

If you only unplug it, it will blow and leak fuel from the purge line.

Seen this several times.


The problem is your canister valve is stuck open. When you fill it and pressure builds in the tank with the new cold gas expanding, it floods your engine. The canister charcoal is now saturated with liquid gas and not just fuel fumes. There is no room for expanding gas. Replacing is very recommended. i have seen hoses blow from too much pressure (blows lines off) since the valve is always open and get liquid fuel ALL over the engine.

"No, I said Bud light" is all that comes to mind.

perspective
Posts: 22
Joined: Mon Oct 21, 2013 1:50 pm

Re: car stalls after fill up ep3

Post by perspective » Fri Mar 21, 2014 9:52 am

I changed the solenoid in the tb, I replaced the valve (clubep3 has DIY) that goes attached to the canister and the hoses that connected them. I still have the problem. I've read in some forums that it might be this valve on top of the fuel tank.

the # of the part I changed is 17310-S5A-L31 Evap canister vent shut valve. Still it stalls...A/f goes crazy after fill up for 2 minutes, then is all good until next fill up . Could it be the wiring /connection at valve? How can I determine if the connections are faulty??

Even if I changed the valve, because the canister was flooded it would still cause the problem ? Should I replace the charcoal canister as well?

perspective
Posts: 22
Joined: Mon Oct 21, 2013 1:50 pm

Re: car stalls after fill up ep3

Post by perspective » Mon Mar 24, 2014 5:02 pm

I have a civic si 2004
k20a3
Bought the kpro thru hybrid racing
Kmanager versionV3.3.1 (20 Mar 2014)
prb ecu
the kpro number I'll post it later

Problem happened after kpro, I had stock injectors
and fuel rail when it started .
Also Injen cai and hks exhaust

Now I have rdx injectors
Hybrid Fuel rail and line
Hondata im gasket
Tb gasket
Tb coolany bypass

Still have the problem after changing the solenoid in tb and the evap canister shut valve( the one attached to the canister)

Post Reply