jrsc reflash issues

Questions / support for the K-Series ECU re-flash
Locked
rawhiteballer
Posts: 4
Joined: Tue Feb 17, 2009 7:24 pm
Contact:

jrsc reflash issues

Post by rawhiteballer »

i sent my ecu off feb 9 2009 to you and yes i received it back 3 days later but the problem im having is a major almost like turbo lag problem on a supercharger at full throttle before 5800rpms i mean the car almost just sits there unless i back off throttle and ease in to it. is there a possibility it wasn't reflashed correctly? because I've checked over everything and the supercharger works but it just seems not to be able to keep up with throttle at lower rpm's. it actually feels like negative boost and i didn't know if that was a ECU issue or not?
Dustin Sherrill
User avatar
Hondata
Site Admin
Posts: 9446
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Post by Hondata »

First, what vehicle / engine / supercharger do you have?

Second, before anything else make sure that the MAP sensor can see boost.
Hondata
rawhiteballer
Posts: 4
Joined: Tue Feb 17, 2009 7:24 pm
Contact:

Post by rawhiteballer »

2007 fg2, k20z3, jacksonracing super charger

yes the map sensor can see boost. according to my dashhawk computer its producing -3 to -1 boost at full throttle when i can actually press the pedal down all the way without it lagging
Dustin Sherrill
User avatar
Spunkster
Site Admin
Posts: 19266
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Post by Spunkster »

This is being handled via email, no need for further posts here.
Locked