Stall During Deceleration when Disengaging Clutch

K-Series Programmable ECU installation questions / support issues
Post Reply
DC5teggi
Posts: 10
Joined: Mon Apr 23, 2018 12:59 pm
Location: South Carolina
Contact:

Stall During Deceleration when Disengaging Clutch

Post by DC5teggi » Fri Jul 05, 2019 6:42 am

Hi All,

Quick overview per forum rules:

- Vehicle: 2003 Acura RSX Base
- K-Pro Serial Number: 47443
- KManager Version: 4.3.5.0
- ECU part number/serial number: 37820-PND-A03 / 2062-200505
- K-Pro purchased through HPTautosport (authorized dealer) in March 2018
- Numerous modifications, most relevant to issue include:
-Forged K20A3 rods and pistons (stock K20A3 crank)
-CXRacing Turbo Kit
-EP3 5-speed Stock Transmission (auto to manual swap)
-ACT AR1-HDSS clutch paired with Exedy HF02 lightweight flywheel
-BC0051 Stage 2 Cams paired with BC0050 Springs/Retainers
-80 lb/hr injectors (similar to RC style injectors)
-DW65c fuel pump
- Datalog and related calibration attached

The issue I am having is that my engine will stall (quite repeatably) whenever I disengage the clutch during a deceleration with throttle off around the 1200-2500 rpm range. The chance of stall dramatically increases with accessory load (particularly air conditioning). With the lightweight flywheel I'm using (and somewhat regret for my application), it appears as though the IACV cannot catch idle quickly enough to prevent the stall, and the stall happens extremely quickly when clutching in.

I have tried a cleaned and new IACV, cleaned the throttle body, made minor adjustments to the throttle stop screw, re-calibrated the TPS numerous times, checked vacuum connections, and tried multiple iterations of the IAC duty cycle adjustment. So far, none of these attempts have made any detectable impact on the stalling issue.

For reference, if I allow the revs to drop to nearly idle (down to ~1,000 RPM with idle set at 925), this issue rarely (if ever) happens. This just isn't a practical solution for daily driving, which is the intended use of my car.

Also, the calibration attached is locked in to the 0° cam angle, since that is what I'm currently tuning, but this issue has always existed in all of the calibrations I've used.

I have seen many threads on various forums that describe similar problems, but I've yet to encounter anyone posting a definitive solution. I am currently suspecting that the lightweight flywheel is the majority of the problem for my application, but I'm also curious if this is strictly exaggerating some other underlying issue.

Does anyone have any suggestions for something else I can try in K-Pro?

Thanks for reading!
Attachments
190407 - 0 cam stall.kdl
Datalog of the stall
(142.18 KiB) Downloaded 18 times
K20A3 e10 disc 190407-0.kal
Calibration
(147.2 KiB) Downloaded 20 times
2003 Acura RSX - K20A3
PND ECU with K-Pro v4

User avatar
Spunkster
Site Admin
Posts: 17940
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: Stall During Deceleration when Disengaging Clutch

Post by Spunkster » Fri Jul 05, 2019 9:33 am

You might try using a PRB based calibration instead as it has additional options for idle and throttle you might find helps in this situation. You might also consider using a normal flywheel if the car is daily driven.

DC5teggi
Posts: 10
Joined: Mon Apr 23, 2018 12:59 pm
Location: South Carolina
Contact:

Re: Stall During Deceleration when Disengaging Clutch

Post by DC5teggi » Fri Jul 05, 2019 11:36 am

Thanks for the really quick reply, Spunkster.

A normal flywheel is what I am most strongly considering. I just want to be sure that I'm not masking a different underlying problem when doing so.

I haven't ventured into the PRB based calibrations yet, since I don't want to lose my secondary runners. This is why I've requested the features you mentioned for PND calibrations in the KManager requests. If I ever decide to replace my IM, though, I would have no issue trying a PRB calibration.
2003 Acura RSX - K20A3
PND ECU with K-Pro v4

SLOEP3
Posts: 2
Joined: Tue Jun 18, 2019 7:50 pm

Re: Stall During Deceleration when Disengaging Clutch

Post by SLOEP3 » Thu Jul 18, 2019 8:39 am

Off subject but do you have a link to the rods you used

DC5teggi
Posts: 10
Joined: Mon Apr 23, 2018 12:59 pm
Location: South Carolina
Contact:

Re: Stall During Deceleration when Disengaging Clutch

Post by DC5teggi » Tue Jul 23, 2019 11:39 am

PMed for the off-topic reply.

On topic, Exedy does not believe that the stalling is an issue related to using a lightweight flywheel. They suspect a tuning issue, and I can't test this since PND tunes don't allow overrun adjustment.

A quick question for Hondata, though. On a PRB calibration, the checkbox for secondary runners is grayed out but is "checked." Are they by chance activated by default when using a PND ECU with a PRB application, or would I indeed be locked into the long runner?
2003 Acura RSX - K20A3
PND ECU with K-Pro v4

User avatar
Spunkster
Site Admin
Posts: 17940
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: Stall During Deceleration when Disengaging Clutch

Post by Spunkster » Tue Jul 23, 2019 11:55 am

You will not have the secondary runner control in a PRB calibration. But you can still try a PRB calibration to see if it helps.

Brian_dc2
Posts: 6
Joined: Sun Aug 04, 2019 5:18 pm

Re: Stall During Deceleration when Disengaging Clutch

Post by Brian_dc2 » Fri Aug 09, 2019 8:24 am

i have a similar problem but i have an internally stock k20z3, my vehicle whenever it begins to roll once its warmed up, even without throttle the rpms will drop. anyways bump to see what results you find

User avatar
Spunkster
Site Admin
Posts: 17940
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: Stall During Deceleration when Disengaging Clutch

Post by Spunkster » Fri Aug 09, 2019 9:02 am

I would recommend starting your own thread and include the calibration and a datalog showing the issue.

Brian_dc2
Posts: 6
Joined: Sun Aug 04, 2019 5:18 pm

Re: Stall During Deceleration when Disengaging Clutch

Post by Brian_dc2 » Fri Aug 09, 2019 3:01 pm

Spunkster wrote:
Fri Aug 09, 2019 9:02 am
I would recommend starting your own thread and include the calibration and a datalog showing the issue.
i actually did and you commented saying to post the cal, since that time i have posted the datalog and my calibration

DC5teggi
Posts: 10
Joined: Mon Apr 23, 2018 12:59 pm
Location: South Carolina
Contact:

Re: Stall During Deceleration when Disengaging Clutch

Post by DC5teggi » Tue Aug 13, 2019 9:38 am

Brian_dc2 wrote:
Fri Aug 09, 2019 8:24 am
i have a similar problem but i have an internally stock k20z3, my vehicle whenever it begins to roll once its warmed up, even without throttle the rpms will drop. anyways bump to see what results you find
No real update yet - just managing the stall by leaving A/C off during stop and go and waiting to disengage the clutch until I'm near idle speed.

I did notice the other day that my auto tensioner was bouncing erratically when the A/C kicked on. Planning to replace that since it has 160k on it and see if it improves anything, but I'm not confident on that.
2003 Acura RSX - K20A3
PND ECU with K-Pro v4

Post Reply