204 F cruising on highway. Too hot?

Post your non-Hondata questions / problems here.
Locked
ITR 1102
Posts: 148
Joined: Sun Sep 10, 2006 9:52 am
Location: Topeka, KS
Contact:

204 F cruising on highway. Too hot?

Post by ITR 1102 » Tue Jun 15, 2010 11:00 am

Is this overly hot? It is only 80 degrees outside, so I feel that it is.

The car is supercharged, but still...
I have a Mishimoto performance radiator.
When I slow down, the temps drop down to about 197 (according to Hondata S300 datalog).

The motor is only 2 years old, as is water pump, etc. I can't think of anything that would cause this.
The thermostat is an Autozone thermo, but stock temperature supposedly.

newsoltsc
Posts: 98
Joined: Fri Oct 09, 2009 11:49 am
Location: Bay Area, CA
Contact:

Post by newsoltsc » Tue Jun 15, 2010 11:44 am

Any coolant leaks?

I had the same issue a few days ago.

I was low on coolant and kept having to refill it. I didnt see a coolant leak anywhere under the car.

It happens that I was leaking coolant from the heater hose that connected to the heater core and it was leaking into my car.
-Jose

ITR 1102
Posts: 148
Joined: Sun Sep 10, 2006 9:52 am
Location: Topeka, KS
Contact:

Post by ITR 1102 » Tue Jun 15, 2010 3:36 pm

Well, I don't have any leaks. The fluid is full and stays full. I bled the system when I filled it after swapping radiators. LHT advised that I upgrade my radiator, assuming that my stock one was old and no longer efficient.

I wish I knew the MPH that my Mishimoto 12" slim fans stalled at. If it is high enough, I could overide the fan in SManager and help it out a bit.

ITR 1102
Posts: 148
Joined: Sun Sep 10, 2006 9:52 am
Location: Topeka, KS
Contact:

Post by ITR 1102 » Mon Jun 21, 2010 10:30 am

Update:

I put a 170 * F thermostat in, drained entire system and filled with 75% water, 25% Honda Blue coolant, and added a bottle of water wetter to the mixture.

I removed the fan shroud and installed both 12" Mishimoto dual slim fans.
I set the fan control override to 178 * F, with a maximum MPH at 115.
(I think the air flow to the radiator is so restricted that the fans are never able to stall????).

Driving in town at about 95 * F outside, the temps will be about 202 * F. If using A/C, the coolant temp reaches that faster than without A/C.
On the highway, the temp will go up to 216 * F.

If I do a 4th gear pull on the highway, the coolant temps drop down to about 192 and hold for a couple minutes before increasing again.
If I turn the heater on full, the temps will drop below 188.

Is this normal? Surely I am not generating THAT much heat with the JRSC while cruising. The LHT race heat exchanger must be blocking too much airflow....

Advice please.

newsoltsc
Posts: 98
Joined: Fri Oct 09, 2009 11:49 am
Location: Bay Area, CA
Contact:

Post by newsoltsc » Mon Jun 21, 2010 11:11 am

What kind of radiator are you using? Half size or full size? Also is it dual core?

Does it over heat at idle?
-Jose

allm0t0rGSR
Posts: 117
Joined: Tue Jun 23, 2009 10:51 pm

Post by allm0t0rGSR » Mon Jun 21, 2010 4:37 pm

try to take out your thermostant or change but not honda thermostant, i had the same problem too...

Locked