DTC P050A Cold Start Idle Air Control System Performance

FlashPro questions & answers specific to the 2010 CR-Z (US, Euro & Asia)
Post Reply
William5683
Posts: 10
Joined: Wed May 02, 2012 8:25 am
Location: Williamsburg Virginia

DTC P050A Cold Start Idle Air Control System Performance

Post by William5683 » Tue Apr 02, 2013 10:02 am

I need help for anyone that has experienced this specific DTC while changing certain areas of their calibration. On my 2011 CR-Z I am running the latest Bata 1.4.7 release. When I updated I noticed a lot of new OBD2 error codes enablers under the MISC tab at the end of the Calibration, more specifically for the EVAP system, and another enable check that I can’t remember at the moment its name (at work). One of the changes I did on my calibration was I disabled the MAF sensor; I figured since I am using the MAP type tuning anyway that I could go ahead and uncheck it and just utilize the air temp sensor that is still being used by the ECU from that MAF already. I ran a data log and watched the sensors in real time and everything looks good. However after the ECU cycles awhile which usually takes the day sometimes shorter since I drive 178 miles a day. I only get this error in the morning usually or at a random time after the car has cooled all the way down and is started again. A couple of notes, the car has 70,000 miles on it, but the engine only as about 36,000 since the last one was replaced due to sucking up some water (storm with CAI) however the IAC still has 70K on it. Since then I have replaced the intake with a Takata unit. The EGR has been removed, block plate installed, and disabled, I plan to supercharge in the near future, so the EVAP is disabled currently since I have heard that if there is any type of leaks under boost the EVAP solenoid tends to cause a DTC to happen. Any thoughts? I really would appreciate it.
Attachments
Raceline 20130330CR-Z.fpcal
This is the calibration with the AFM disabled causing the DTC code when the car starts up cold
(10.03 KiB) Downloaded 260 times
Datalog-130403-002.fpdl
this is when the ECU did put up the DTC code it took about 6 seconds after I started the car
(8.76 KiB) Downloaded 241 times
Datalog-130403-001.fpdl
this is the datalog before the DTC code triggered when i restarted the car later that morning
(34.95 KiB) Downloaded 230 times
Last edited by William5683 on Wed Apr 03, 2013 10:09 am, edited 2 times in total.

User avatar
Spunkster
Site Admin
Posts: 17861
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: DTC P050A Cold Start Idle Air Control System Performance

Post by Spunkster » Tue Apr 02, 2013 10:07 am

Try the return it to stock option and see if the problem persists, if it does then you need to follow the steps Hondata gives for troubleshooting that specific error code.

William5683
Posts: 10
Joined: Wed May 02, 2012 8:25 am
Location: Williamsburg Virginia

Re: DTC P050A Cold Start Idle Air Control System Performance

Post by William5683 » Tue Apr 02, 2013 2:57 pm

I will try that thank you

Post Reply