Flashpro Help - "Unknown Vehicle" and cannot see VIN

FlashPro questions & answers specific to the 2007-2008 US TSX
Blulude98
Posts: 38
Joined: Fri Oct 23, 2009 4:11 am

Flashpro Help - "Unknown Vehicle" and cannot see VIN

Post by Blulude98 » Thu May 09, 2019 3:46 am

Flash Pro Serial FP-TSX-US-90305
TSX ECU: 37820-RBB-A71
Having a problem to connect TSX ECU with Flashpro.
Have recorded VIN in ECU but cannot upload any calibrations or connect to FlashPro.
Attached below are the error messages.
Vehicle Model: Unknown
Vehicle Family: Unknown.
Cannot see VIN no in History tab??
What am i doing wrong?
Please help.

Blulude98
Posts: 38
Joined: Fri Oct 23, 2009 4:11 am

Re: Flashpro Help - "Unknown Vehicle" and cannot see VIN

Post by Blulude98 » Thu May 09, 2019 3:57 am

Image
Image
Image

User avatar
Spunkster
Site Admin
Posts: 17859
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: Flashpro Help - "Unknown Vehicle" and cannot see VIN

Post by Spunkster » Thu May 09, 2019 9:15 am

What vehicle is this being used in? What is the ECU part number?

Blulude98
Posts: 38
Joined: Fri Oct 23, 2009 4:11 am

Re: Flashpro Help - "Unknown Vehicle" and cannot see VIN

Post by Blulude98 » Thu May 09, 2019 2:09 pm

TSX ECU: 37820-RBB-A71 is being used.
Vehicle that i am using is a Australian 2004 Honda Accord Euro.

User avatar
Hondata
Site Admin
Posts: 8721
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: Flashpro Help - "Unknown Vehicle" and cannot see VIN

Post by Hondata » Thu May 09, 2019 3:13 pm

I believe that it does not recognize the part number. Use 'send support information to Hondata' and we will see.
Hondata

Blulude98
Posts: 38
Joined: Fri Oct 23, 2009 4:11 am

Re: Flashpro Help - "Unknown Vehicle" and cannot see VIN

Post by Blulude98 » Fri May 10, 2019 5:56 am

information has just been sent to Hondata support as requested.

User avatar
Hondata
Site Admin
Posts: 8721
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: Flashpro Help - "Unknown Vehicle" and cannot see VIN

Post by Hondata » Fri May 10, 2019 7:31 am

The ECU is not reporting a calibration ID nor part number so the FlashPro cannot recognize it.
Hondata

Blulude98
Posts: 38
Joined: Fri Oct 23, 2009 4:11 am

Re: Flashpro Help - "Unknown Vehicle" and cannot see VIN

Post by Blulude98 » Fri May 10, 2019 6:04 pm

Ok so does this mean I have a issue with the flash pro unit or the ecu?
Also what do I do to fix the issue?

User avatar
Hondata
Site Admin
Posts: 8721
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: Flashpro Help - "Unknown Vehicle" and cannot see VIN

Post by Hondata » Fri May 10, 2019 6:08 pm

It is the ECU. What's the full story - vehicle, origin of the ECU, any changes to the ECU etc.
Hondata

Blulude98
Posts: 38
Joined: Fri Oct 23, 2009 4:11 am

Re: Flashpro Help - "Unknown Vehicle" and cannot see VIN

Post by Blulude98 » Sat May 11, 2019 2:52 am

No story to tell actually.
TSX ECU came from a stock standard Accord TSX from the US which still runs the car fine.
What do i do next to resolve this issue?

User avatar
Hondata
Site Admin
Posts: 8721
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: Flashpro Help - "Unknown Vehicle" and cannot see VIN

Post by Hondata » Sat May 11, 2019 8:03 am

If the ECU runs the vehicle, has the immobilizer been matched or disabled?
Hondata

Blulude98
Posts: 38
Joined: Fri Oct 23, 2009 4:11 am

Re: Flashpro Help - "Unknown Vehicle" and cannot see VIN

Post by Blulude98 » Sat May 11, 2019 5:32 pm

Yes the immobilizer has been matched and it is starting the vehicle.
datalogging also works when flashpro is connected.
just cant upload a calibration map.

User avatar
Hondata
Site Admin
Posts: 8721
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: Flashpro Help - "Unknown Vehicle" and cannot see VIN

Post by Hondata » Sun May 12, 2019 12:23 pm

The ECU is not reporting a calibration ID nor part number. That is the problem.
Hondata

Blulude98
Posts: 38
Joined: Fri Oct 23, 2009 4:11 am

Re: Flashpro Help - "Unknown Vehicle" and cannot see VIN

Post by Blulude98 » Thu May 16, 2019 4:42 am

How do i make the ecu report a calibration ID and part number?

User avatar
Hondata
Site Admin
Posts: 8721
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: Flashpro Help - "Unknown Vehicle" and cannot see VIN

Post by Hondata » Thu May 16, 2019 8:46 am

It is either the FlashPro, wiring or ECU. The FlashPro is reading the battery voltage and VIN, so it looks ok. Likewise the wiring is ok since the FlashPro can read the previous two items. However the FlashPro cannot see the ECU serial number which it needs to determine what the ECU is. So it most likely is the ECU.
The next steps to narrow it down would be to the FlashPro into another vehicle and check that it recognizes the ECU and /or use another ECU on you vehicle.
People disable the immobilizer by altering the ECU, which also disables the serial number, which is why I asked about the immobilizer.
Hondata

Post Reply