DTC P1659 TSX 12, ETCS control relay malfunction.

FlashPro questions & answers specific to the 2007-2008 US TSX
Post Reply
R2Racing
Posts: 21
Joined: Thu Apr 26, 2012 10:12 am

DTC P1659 TSX 12, ETCS control relay malfunction.

Post by R2Racing » Tue Jun 14, 2016 9:01 am

Hi Everybody

We have already second car with such issue. Both are CU2 2012 TSX Ecu and FlashPro, hybrids on CL9 head. Everything is doing well, exept that DTC P1659, only during a start, mostly when cold. ETCS control relay malfunction.

List what we replaced
- Throttle body
- ETCS control relay
- ECU , even tried stock one w/o FP

Any ideas, guys?

Dmitry

User avatar
Spunkster
Site Admin
Posts: 17848
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: DTC P1659 TSX 12, ETCS control relay malfunction.

Post by Spunkster » Tue Jun 14, 2016 9:39 am

Have you followed the troubleshooting steps in the factory service manual for that error code?

R2Racing
Posts: 21
Joined: Thu Apr 26, 2012 10:12 am

Re: DTC P1659 TSX 12, ETCS control relay malfunction.

Post by R2Racing » Wed Jun 15, 2016 5:29 am

Spunkster wrote:Have you followed the troubleshooting steps in the factory service manual for that error code?
sure, electrician checked all routines couple times.
I decided to ask your advise just after another one case. The common thing is both are CU2 and run FlashPro. And we did not see such DTC on earlier made hybrids. Just guessed might be some changes was made in software ?

Thanks
Dmitry

User avatar
Spunkster
Site Admin
Posts: 17848
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: DTC P1659 TSX 12, ETCS control relay malfunction.

Post by Spunkster » Wed Jun 15, 2016 9:28 am

There is nothing that has been done that should cause this.

R2Racing
Posts: 21
Joined: Thu Apr 26, 2012 10:12 am

Re: DTC P1659 TSX 12, ETCS control relay malfunction.

Post by R2Racing » Fri Jul 29, 2016 5:11 am

we are still fighting with issue described above. Most probably, a reason is in immobilizer system. When first start, HDS shows status of immo - RUN, during cranking it's changing to BAN, green key starts blinking. Second start with the same way. And, finally, it does start after 3rd attempt. Always 3rd attempt.

I think, ETSC DTC is just an effect of going BAN status during cranking.

Spunkster, what could you advise where to check? I believe you know logic of immobilizer system better than any )
All components - MICU, receiver and key are stock, and no any mods there.

Dmitry

User avatar
Spunkster
Site Admin
Posts: 17848
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: DTC P1659 TSX 12, ETCS control relay malfunction.

Post by Spunkster » Fri Jul 29, 2016 9:45 am

This may be because you are using these ECUs in vehicles they were not designed for. We don't change anything with how the immobilizer works. You may have a faulty immobilizer, key or wiring in the vehicle.

R2Racing
Posts: 21
Joined: Thu Apr 26, 2012 10:12 am

Re: DTC P1659 TSX 12, ETCS control relay malfunction.

Post by R2Racing » Mon Sep 12, 2016 11:17 am

For everybody who will be googling similar issue. The problem solved. It was just just fake ngk spark plugs. Nobody could not even imagine such reason affected immo, but thats it.

At first immo goes BAN status during cranking cause of interferences, than ECU switches off power supply for DBW particularly, and few different DTCs than, depends of how long are you cranking. When these plugs were already warm - no any problem to start.

Take care, guys

Dmitry
R2Racing

Chrisnjhardcore
Posts: 1
Joined: Mon Mar 26, 2018 5:01 pm

Re: DTC P1659 TSX 12, ETCS control relay malfunction.

Post by Chrisnjhardcore » Mon Mar 26, 2018 5:05 pm

Hey what’s up,I am having the same issue with my 2011 TSX not starting but will start on the 3rd try every time,I also purchased NGK plugs from EBay my question is when your car did start on the 3rd try did the check emissions and check VSA light come up?

Post Reply