03-06 CAN adapter harness problem(Accord Euro)

FlashPro questions & answers specific to the 2007-2008 US TSX
Mounty
Posts: 25
Joined: Thu Jun 14, 2012 7:44 am

Re: 03-06 CAN adapter harness problem(Accord Euro)

Post by Mounty » Wed Mar 13, 2013 12:43 pm

Zoro2006 wrote:
majork wrote:i've soldered hondata harness on E connector
- red on Low can (red with 2 grey dot )
- white on high can (white with 2 grey dot)
one of solutions if you can't find CAN connector in the car ;)
It depends... I don't know if it is only the exe model, but all of my CAN connector under the glove box were full.. and to get a soldering iron up in there was much (!!!) more difficult, so i too connected right into the harness, about 7 cm from the ecu e plug. Way more room for soldering, and unplugging wires/connector..

majork
Posts: 10
Joined: Sun Feb 10, 2013 6:12 am

Re: 03-06 CAN adapter harness problem(Accord Euro)

Post by majork » Tue Mar 19, 2013 1:45 am

Soldering is the working way :) immo paired with ecu time to install all stuff. Cos i can t find fast clips to clamp on wires may be next time i ll do that

mabo
Posts: 64
Joined: Sun Mar 18, 2012 2:21 pm

Re: 03-06 CAN adapter harness problem(Accord Euro)

Post by mabo » Sun Mar 31, 2013 4:15 pm

I guess that - cant find VIN in the ECU - caused by the fact that ECU was a new one, VIN is blank in new ECUs, dealer must program your actual VIN during ECU replacement procedure.

Colour of the wires doesnt matter, just check if you installed CAN pins in proper holes of OBD connector and your flashpro manager see the ECU ( connected ) , if not - swap 2 wires and problem solved.

Mounty
Posts: 25
Joined: Thu Jun 14, 2012 7:44 am

Re: 03-06 CAN adapter harness problem(Accord Euro)

Post by Mounty » Wed May 01, 2013 1:10 pm

Had the same problem, that the pins were deep enough in the obdII (female) side, but when i shoved the male side in, it pushed the pins back out..
Fix: applied cableties to the cables, nice and snug, a few cables together, AND dripped some crazy/super glue into the pin holes over the cables/wires (from behind/held horizontally as not to cause a bad/faulty connection !!), THEN added an obdII extension cable, ran it across to the passenger footwell.
Reason: Now the obdII connector is not longer wrapped around my steering column/hanging around my feet during datalogs/retunes/reflashes etc. and it is always there... no need to finger around "in the dark" trying to fit the male end.. when not in use, i just push the extension back into/under the middle console (carpet) so no passenger feet/moisture can touch it... could probably have laid the extension up into the glove box, but driving around with an open box seemed a bit absurd... also have other stuff installed there (video/mp3 interface) so room is not abundant...
Pix tomorrow...
Mounty

majork
Posts: 10
Joined: Sun Feb 10, 2013 6:12 am

Re: 03-06 CAN adapter harness problem(Accord Euro)

Post by majork » Sat May 04, 2013 8:35 am

waiting for :)

Mounty
Posts: 25
Joined: Thu Jun 14, 2012 7:44 am

Re: 03-06 CAN adapter harness problem(Accord Euro)

Post by Mounty » Thu May 09, 2013 1:25 am

Hi Majork, my friend, sorry took longer.... please forgive me?? Here are the pix:
OBD plug from car NOT plugged back into the "holder" and extension plugged in
Image

Extension has "straight" ends, no 90 degree angled plugs available, so I did it this way...
Image

Ran the cable up under the steering column, leaving enough slack (extra) so the column can still be moved without the cable being in the way....
Image

Extension runs down behind the driver side console cover, where the ECU sits, and comes out behind the passenger console cover/air duct...
Extension extracted, ready to use:
Image

Extension retracted, when not in use:
Image

Hope this is helpful!!!
Mounty

K_A_N_O
Posts: 38
Joined: Sun Jul 08, 2012 2:15 pm
Location: United Kingdom

Re: 03-06 CAN adapter harness problem(Accord Euro)

Post by K_A_N_O » Wed May 15, 2013 9:36 am

FlashPro works perfectly with our UKDM CL9's all you need is an acura TSX 07-08 ecu, part number 37820-RBB-A21.

and of course FlashPro itself, part number FP-TSX-US

depending on the year of your accord depends on if you need the can bus adapter harness. (only two wires)

pre facelift CL9's (03-06) dont support CAN BUS so you will need the adapter harness.

or you can make your own if you can source two pins that you need to put into the obd2 socket.

first remove the panel from under the steering wheel.
on the right you will see these plugs.
Image

the plug you need to plug into or solder from is the grey plug with the white, red and brown wires in. each row in this plug is common so all the reds are linked all the whites are linked and so are the browns so if your soldering the wires on you dont need to worry which wires you pick.

behind those plugs you can pop the panel out of the dash so you can remove the plugs so you can pull the towards you, makes it easier.

if your soldering then..
first you want to remove the brown tape from around the red and white wires as far down as you can to give you enough room to get at the wires.
then just solder one wire to the red and one to the white. easy peasy. be sure to insulate the cable afterwards you dont want them shorting out. a good tip is stagger where you join the wires together ;)

i dont have any pictures as i didnt do it this way but its pretty easy to explain.

next step is a pain in the backside.

pop the obd2 socket out of its holder.

download this pdf and read this will help for this part.
http://www.hondata.com/downloads/04-06_ ... nstall.pdf

skip to page two and start from step 3.
step 4 is tricky.

once you have popped both retainers out of the sides of the obd2 plug first you need to take the the grey wire out from pin position 14 and move it to position 1.

then you need to take your pins you have got from another obd2 plug and solder them onto the ends of your red and white wires.

the white wire then needs to be inserted into position 6 and red to 14.

then push the retainers back in on the plug and put it all together :good:

i used hondatas adapter harness mine looks like this
Image

Image

Image

the red and white wires push straight into the two spare holes in the furthest left grey plug that only has the brown wire in.

i used a spare plug though as you can see mine is the white plug in the grey connector block.
05 UKDM CL9 Accord.

K_A_N_O
Posts: 38
Joined: Sun Jul 08, 2012 2:15 pm
Location: United Kingdom

Re: 03-06 CAN adapter harness problem(Accord Euro)

Post by K_A_N_O » Wed May 15, 2013 9:37 am

just copied my post for you all thats how mine looks.

as you can see the can bus connector is grey, not green.
05 UKDM CL9 Accord.

Post Reply