cant upload cal to ecu

FlashPro questions & answers specific to the 2007-2008 US TSX
core58
Posts: 20
Joined: Mon Jan 09, 2012 2:35 pm

Re: cant upload cal to ecu

Post by core58 »

mabo wrote:Yep core58 , i also dont see nothing annoying here ,
no i mean this IS annoyning
User avatar
Spunkster
Site Admin
Posts: 19350
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata

Re: cant upload cal to ecu

Post by Spunkster »

We are investigating the issue. The problem is related to voltage and it would appear to be specific to the TSX . Honda's ECU programming procedure recommends attaching a battery charger. Increasing the battery voltage while programming helps reduce the incidence of the WEN error. Could we get an indication of the year of the TSX that this problem is occurring in?

Name:
Vehicle:
Year:
FP Serial#:
mabo
Posts: 64
Joined: Sun Mar 18, 2012 2:21 pm

Re: cant upload cal to ecu

Post by mabo »

I found few of your posts bout this error and that low voltage is the problem so I fully charged my battery and connected Ctek charger on top in a power supply mode. Cant imagine more stable voltage situation in my case, I even never start engine after charging battery but nothing changed, WEN error.

The only way i can flash my ecu - engine run for 10-15 mins, no matters idle or in a regular drive. Interior heater must be on, without it i cant flash even after 20 minutes of engine run.

Please exclude wiring problem out of your investigation, its 10000% not wiring problem.

Vehicle: EDM Accord CL9 with 08 TSX in it
Year: 2007
Serial#: Serial number of ecu ? flashpro ?
core58
Posts: 20
Joined: Mon Jan 09, 2012 2:35 pm

Re: cant upload cal to ecu

Post by core58 »

Vehicle: EDM Accord CL9 + 07 TSX ECU / manual
Year: 2006
FP Serial#: FP-TSX-US-90028
mabo
Posts: 64
Joined: Sun Mar 18, 2012 2:21 pm

Re: cant upload cal to ecu

Post by mabo »

Yesterday i had to flash multiple cals to make few datalogs. I run my car , then stopped to upload new cal to flashpro or ecu, again and again. I can clearly say now that its really voltage issue coz everything else was constant. Leaving car with headlights on or rear window heater on for few minutes with engine off is enough to drop battery voltage to get WEN error , then 3-4 minutes of idling with everything turned off is enough to bump voltage for flashing. I bet 5 bucks that its not a flashpro problem, it maybe some kind of ecu fw routine to check voltage before it let to flash. Maybe you can find that code and patch it , im not gonna flash my car anymore after i finish tune but now its really annoying.
mabo
Posts: 64
Joined: Sun Mar 18, 2012 2:21 pm

Re: cant upload cal to ecu

Post by mabo »

This problem get worse and worse , today i wasnt able to flash my ecu after 30 min run. I also tried to flash with charger , checked voltage on battery pins - 14.4 volts , when i turn ignition on it drops to 11.9 - 12.2 and still WEN error. Hondata , please find why it happens with tsxers and solve this if possible.
Bard
Posts: 48
Joined: Wed Nov 25, 2009 2:53 am
Location: Russia, Magadan

Re: cant upload cal to ecu

Post by Bard »

It looks like a soldering issue :) that i had on my Pioneer, when after night in winter -25 Celsius i start a car and start my cd player it plays except left side speakers when aux input is enabled, if i switch to radio or cd than everything plays correctly. I warm a car, turn heater enable aux on pioneer and started to wait, that after 10-15 minutes when it is warm in a car, with a grinding sound left side speakers started to play and after one minute everything played great! I have checked an aux cable ten times everything seems was right, i have cut a part of it and re soldered it, then the problem dissapeared. :))
Bard
Posts: 48
Joined: Wed Nov 25, 2009 2:53 am
Location: Russia, Magadan

Re: cant upload cal to ecu

Post by Bard »

Any one tryed to heat ecu or flashpro with a hairdryer ?
core58
Posts: 20
Joined: Mon Jan 09, 2012 2:35 pm

Re: cant upload cal to ecu

Post by core58 »

Bard wrote:Any one tryed to heat ecu or flashpro with a hairdryer ?
not really yet.

Bard, do you experience just the same issue ?
if so, pls post your data
Bard
Posts: 48
Joined: Wed Nov 25, 2009 2:53 am
Location: Russia, Magadan

Re: cant upload cal to ecu

Post by Bard »

No cause i still using k-pro dual harness, i do not have an ability to flash ecu to my vin, here is no Acura or Honda dealer or some one else with scanner.
tsxdan1116
Posts: 1
Joined: Fri Dec 19, 2014 4:05 pm

Re: cant upload cal to ecu

Post by tsxdan1116 »

my ecu is in recovery mode and i cant upload calibration same error everytime the wen pin..the worst thing is i cant warm up my car because is in recovery mode..help pls
User avatar
Hondata
Site Admin
Posts: 9477
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: cant upload cal to ecu

Post by Hondata »

What is the FlashPro serial number? If possible take your ECU and install into another vehicle. That often works to get it out of recovery mode if the vehicle wiring gives a low WEN voltage.
Hondata
CivicVTi
Posts: 287
Joined: Mon Dec 15, 2003 1:51 pm
Location: Athens, Greece

Re: cant upload cal to ecu

Post by CivicVTi »

I also occasionally the same error in my Euro Accord CL9 with TSX ECU and FP. Solutions up to now that worked for me (all together or just one in some cases):
1. Make sure the ECU ground is VERY good (originally on the intake manifold, I moved it on the valve cover).
2. CTek charger in power supply mode
3. Drive 5-10 minutes
Post Reply