Throttle plate closing @ high rpm

FlashPro Manager software
User avatar
Hondata
Site Admin
Posts: 8781
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: Throttle plate closing @ high rpm

Post by Hondata » Wed Feb 11, 2015 9:59 am

A good start would be to determine if the TPS outputs (both of them) are the same between the K20 and J37 throttle bodies, measure the throttle plate open / closed positions and see if the DC motor characteristics are the same. That would tell us if the throttle bodies are electrically compatible.
Hondata

VitViper
Posts: 273
Joined: Thu Aug 27, 2009 10:38 pm

Re: Throttle plate closing @ high rpm

Post by VitViper » Wed Feb 11, 2015 12:53 pm

On my car the issue is with the TSX throttle body, I have tested both the TPS outputs -- they are in spec (per Honda's spec) and not any different from the stock TB.

The J37 I cannot test as this is a remote customer's car, *however*, the J37 is commonly used on these cars (and the ZDX) as well as the 9th gen Civic with no troubles, I fail to understand how just this one car would be "rejecting" (for fail of a better term) the throttle body -- when the issue is present with the 100% OEM (original TB). I am having him install the OEM TB right now... if that sheds any light. I'm going to work with him to see if he can put a volt meter to both the TPS sensors at rest and full open to see if that helps.

deibral
Posts: 8
Joined: Thu Jun 16, 2016 9:51 am

Re: Throttle plate closing @ high rpm

Post by deibral » Sun Feb 05, 2017 8:41 am

Was this issue ever resolved? I've had the same problem on dyno recently, reving the car to 8500 rpm on WOT. Every time it was reved, I got the check engine light and the TB was going into some kind of limp mode reving 2000-3000 rpm constantly. Then had to clear DTC manually to get it work again.

The TB is J37 on K24/K20 frank with Flashpro 2.4.9. Never had such problems before.

User avatar
Spunkster
Site Admin
Posts: 18018
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: Throttle plate closing @ high rpm

Post by Spunkster » Mon Feb 06, 2017 4:58 pm


Post Reply