FlashPro V1.6.3

FlashPro Manager software
Locked
User avatar
Hondata
Site Admin
Posts: 8811
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

FlashPro V1.6.3

Post by Hondata » Fri Jul 12, 2013 11:43 am

This has support for the International Accord and the Acura RDX

See FlashPro for model / part numbers.

Download here

V1.6.3 (28 Oct 2013)
  • Traction control firmware 8 - added launch compensation
  • FlashPro firmware updated to version 60
  • Removed current driving cycle from OBDII diagnostics readiness display.
  • Fixed shift F1 opening help file rather then lambda overlay
  • [2006 Civic Si] Added fuel tank pressure and purge duty sensors.
  • [Civic Race] Automatically set EVAP VSV open
  • [R18 Civic] Fixed upload when in recovery mode for some ECUs
  • [ILX] Added support for the R9B-A03 ECU
  • [TL] Added support for 04-06 TL and 03-07 V6 Accord with adapter harness
V1.6.2 (1 October 2013)
  • FlashPro firmware updated to version 59
  • [Civic R18] Added support for 37805-RNA-A840
  • [Accord International] Added support for 37805-RL6-S510
  • When unlocking ask if the FlashPro is being sold
V1.6.1 (5 September 2013)
  • FlashPro firmware updated to version 58
  • Added support for US RDX 2007-2012
  • [2012+ Civic Si, ILX] Added VTC deceleration control
  • [CR-Z] Fixed 2012 CRZ throttle table pedal index
V1.6.0 (11 July 2013)
  • Added support for International Accord 2008-2010
  • [S2000 Euro] Fixed fuel pressure display unit
  • [Civic R18] Added disable for misfire detection in MT
Hondata

sass
Posts: 104
Joined: Mon Oct 06, 2008 5:07 am
Location: Evropa-Estonia-Tallinn

Re: FlashPro V1.6.0

Post by sass » Tue Jul 16, 2013 2:41 am

Hondata
3 (three) Hondata ECUs of my clients´ Honda Accord 2010 have erro coded P0128. This error is fixed for Civic K24 2012. Is it possible to fix it for other Hondas too?
Ilx 2013
Tsx 2009-2010
International Accord 2008-2010

Add:
When we activate secondary water sensor the error p0128 does not appear. But in that case on the moment when fan starts, engine temperature is abt 106C.
We deactivate secondary sensor and once in three days get error coded p0128 but on that moment water temp is less than 95C.
Cr-v RD8+K24A2turbo+Kpro V4 prb+NPR3/6Speed+ТС+ HFS4 v3.2.
DynoWheel = 472kW / 589 N.m
HRX One Mile Challenge = Max Speed 282km
Known as Sniper

User avatar
Hondata
Site Admin
Posts: 8811
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: FlashPro V1.6.0

Post by Hondata » Tue Jul 16, 2013 6:30 am

What vehicles / ECUs are involved, and what FlashPros are being used?

We've only just started selling the Accord FlashPro, so it seems like you may be using the TSX FlashPro. Is that the case?
Hondata

sass
Posts: 104
Joined: Mon Oct 06, 2008 5:07 am
Location: Evropa-Estonia-Tallinn

Re: FlashPro V1.6.0

Post by sass » Tue Jul 16, 2013 8:12 am

Hondata wrote:What vehicles / ECUs are involved, and what FlashPros are being used?

We've only just started selling the Accord FlashPro, so it seems like you may be using the TSX FlashPro. Is that the case?
There are many Accord/TSX 09-10 users in Europe and Russia who use Flashpro.
In 2012 this was the only way to tune up supercharged or turbo cars. Nobody beleived that Flashpro for International Accord will be released.

So, is it possible to add option for TSX Flashpro 09-10?
*Coolant thermostat temperature check enabled (P0128)*
Cr-v RD8+K24A2turbo+Kpro V4 prb+NPR3/6Speed+ТС+ HFS4 v3.2.
DynoWheel = 472kW / 589 N.m
HRX One Mile Challenge = Max Speed 282km
Known as Sniper

human668
Posts: 2
Joined: Tue Jul 16, 2013 4:37 pm

Re: FlashPro V1.6.0

Post by human668 » Tue Jul 16, 2013 4:43 pm

Hello Hondata.
I have a problem with FlashPro V1.6.0.
I updated Flashpro Manager from V1.5.6 to V1.6.0.
It said it was going to update the Flashpro firmware as it normally does. But, this time, the program froze and the power light on my flashrpo just keeps on flashing.

Flashpro serial# FP-CRZ-US-70009
OS: Windows 7

Image

User avatar
Spunkster
Site Admin
Posts: 18059
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: FlashPro V1.6.0

Post by Spunkster » Wed Jul 17, 2013 11:05 am

Have you tried rebooting the laptop and plugging everything back in?

soxfan143
Posts: 216
Joined: Mon Nov 12, 2007 5:09 pm
Location: lynnfield MA

Re: FlashPro V1.6.0

Post by soxfan143 » Thu Jul 18, 2013 12:13 pm

My FP didn't update firmware when upgrading to 1.6.0 from 1.5.6. Was is supposed to?

Also I noticed with the fan control on the Hybrid maps that the fans come on much later than the temp setting I have it at. I have the "Use secondary sensor for fan control" unchecked but with these maps the fans don't come on until like 212-215 when it's set for 199 to come on. With the "Race" cals the fans came on much sooner. The fans used to come on at like 205 max. Any idea why this happens? If you need logs and a cal I'll get one after work. Thanks guys.

User avatar
Spunkster
Site Admin
Posts: 18059
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: FlashPro V1.6.0

Post by Spunkster » Thu Jul 18, 2013 5:03 pm

I have made the software engineers aware of this issue, and they are looking at it.
soxfan143 wrote:My FP didn't update firmware when upgrading to 1.6.0 from 1.5.6. Was is supposed to?

Also I noticed with the fan control on the Hybrid maps that the fans come on much later than the temp setting I have it at. I have the "Use secondary sensor for fan control" unchecked but with these maps the fans don't come on until like 212-215 when it's set for 199 to come on. With the "Race" cals the fans came on much sooner. The fans used to come on at like 205 max. Any idea why this happens? If you need logs and a cal I'll get one after work. Thanks guys.

human668
Posts: 2
Joined: Tue Jul 16, 2013 4:37 pm

Re: FlashPro V1.6.0

Post by human668 » Thu Jul 18, 2013 9:06 pm

Spunkster wrote:Have you tried rebooting the laptop and plugging everything back in?
I waited about an hour, nothing changed. After that I unplugged my flashpro, rebooted my laptop and tried it again. The same thing happened again. The flashpro wasn't usable, the power light kept on flashing.
Then, I reinstalled V1.5.6. It updated the firmware, and things were back to normal.
So, it seems V1.6.0 isn't able to update the firmware of my flashpro.

VitViper
Posts: 273
Joined: Thu Aug 27, 2009 10:38 pm

Re: FlashPro V1.6.0

Post by VitViper » Thu Jul 18, 2013 10:42 pm

Spunkster wrote:I have made the software engineers aware of this issue, and they are looking at it.I have made the software engineers aware of this issue, and they are looking at it.
soxfan143 wrote:My FP didn't update firmware when upgrading to 1.6.0 from 1.5.6. Was is supposed to?

Also I noticed with the fan control on the Hybrid maps that the fans come on much later than the temp setting I have it at. I have the "Use secondary sensor for fan control" unchecked but with these maps the fans don't come on until like 212-215 when it's set for 199 to come on. With the "Race" cals the fans came on much sooner. The fans used to come on at like 205 max. Any idea why this happens? If you need logs and a cal I'll get one after work. Thanks guys.
Seriously guys? I posted about this problem over a month ago... the second ECT sensor is still being used for fan control no matter what on the Civic calibrations.

*cough*

http://www.hondata.com/forum/viewtopic.php?f=29&t=16336

soxfan143
Posts: 216
Joined: Mon Nov 12, 2007 5:09 pm
Location: lynnfield MA

Re: FlashPro V1.6.0

Post by soxfan143 » Fri Jul 19, 2013 10:22 am

Guys what's the deal with the terrible throttle plate control with the hybrid maps? I have a log from the race cals that shows the proper way the throttle plate should behave. The problem I'm having is when shifting or letting off the throttle the plate is not closing fast enough or closing enough. It takes a few ms longer to close properly and when it does close it's staying open about 6%-7% more. With the race cals it closed immediately to 3% but with the hybrid maps it's hanging at 11% for a few ms then it only drops to 9%. this is causing my overrun vacuum to stay up at 20.4 where before it would be down at 24.6. It's causing awful rev hang and terrible shifts. Here are the logs and my current hybrid cal.
Attachments
great throttle plate.fpdl
(84.2 KiB) Downloaded 224 times
crap throtle plate.fpdl
(70.67 KiB) Downloaded 204 times
FR GT30R V80-23 AFM Hybrid.fpcal
(23.46 KiB) Downloaded 236 times

User avatar
Hondata
Site Admin
Posts: 8811
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: FlashPro V1.6.0

Post by Hondata » Fri Jul 19, 2013 1:27 pm

Try changing your VTC deceleration setting to see if that affects the throttle. I believe that the ECU uses the idle learn to work out what throttle position to use when the rpm is dropping, so the length of time after a reflash may change the behavior.
Hondata

soxfan143
Posts: 216
Joined: Mon Nov 12, 2007 5:09 pm
Location: lynnfield MA

Re: FlashPro V1.6.0

Post by soxfan143 » Fri Jul 19, 2013 2:55 pm

Cool. What would you suggest I do with the VTC settings? I have it set exactly how it was in the race cal.

soxfan143
Posts: 216
Joined: Mon Nov 12, 2007 5:09 pm
Location: lynnfield MA

Re: FlashPro V1.6.0

Post by soxfan143 » Fri Jul 19, 2013 2:59 pm

I see what you are saying. My cam on that good log was 3 degrees and with the crappy one it was staying in the 30s. That may help.

soxfan143
Posts: 216
Joined: Mon Nov 12, 2007 5:09 pm
Location: lynnfield MA

Re: FlashPro V1.6.0

Post by soxfan143 » Sat Jul 20, 2013 7:53 pm

Ok guys I've tried just about everything to eliminate the rev hang but it's actually now getting worse. Look at this 4th gear pull. After I let off the throttle the rpms CLIMB like from like 6800 to 7200 with the throttle completely let off. The plate hangs open at 15% for a few ms then only drops to 10% and it's just unbearable. We need to find a way to transfer the race cal throttle logic to the hybrid maps ASAP!! I might have to revert back to the race cals just for this reason. The car shifts like complete poo and is causing lockout at high rpms plus it just sounds awful and makes me look and sound like a total rookie driver. Embarrassing. Here is the log. Same calibration but I'll post it again anyway.
Attachments
even crappier throttle plate.fpdl
(29.15 KiB) Downloaded 219 times
FR GT30R V80-24 AFM Hybrid.fpcal
(23.49 KiB) Downloaded 207 times

Locked