Page 1 of 1

Flashpro crashes after start engine, start a datalog!

Posted: Thu Jun 08, 2017 7:00 am
by R-12914
Since i have updated my Flashpro Manager to Version 2.7.3.0 and Flashpro Firmware to Version 114, my Flashpro crashes always if i start the engine and start directly afterwards a Datalog, if the engine is idling.

With previous Versions i no had this problem/bug!

I have noted the following:

Every time (at least 3 times), if i start a datalog after engine start (idling), the flashpro (without a notebook) starts a datalog for a few seconds.
The Power-LED (shines) and Datalog-LED (flashes), but after a few seconds both LEDs go off, as if the flashpro crashes and then restart again.
If i do this for the 4th time, everything works as usual.

In this incident, each time, short datalogs stored on the Flashpro.

If i drive a few minutes and then start the datalog, everything works as usual.

A similar behavior I have, when I start a datalog (before I start the engine) and then start the engine, then the Flashpro also crashes and stores a short Datalog on it.


The battery is always fully charged and has full capacity and the alternator also works perfectly!

Both variants have worked in previous software/firmware versions!

In this state, it is not possible to datalog the engine cranking or log parameter directly after engine start!

Re: Flashpro crashes after start engine, start a datalog!

Posted: Thu Jun 08, 2017 9:40 am
by Spunkster
What is the serial number that is on the FlashPro?

Re: Flashpro crashes after start engine, start a datalog!

Posted: Thu Jun 08, 2017 10:00 am
by R-12914
Spunkster wrote: Thu Jun 08, 2017 9:40 am What is the serial number that is on the FlashPro?
Car: Honda Civic TypeR, FN2
ECU-Part-Number: 37820-RSP-E03
Flashpro-Seriel-Number: FP-SI-INT-21153

Re: Flashpro crashes after start engine, start a datalog!

Posted: Thu Jun 08, 2017 4:48 pm
by Spunkster
We are looking into this.

Re: Flashpro crashes after start engine, start a datalog!

Posted: Fri Jun 09, 2017 11:36 am
by R-12914
Spunkster wrote: Thu Jun 08, 2017 4:48 pm We are looking into this.
Ok, thank you!

Any news about this issue/bugfix?

Re: Flashpro crashes after start engine, start a datalog!

Posted: Wed Jun 14, 2017 2:48 pm
by R-12914
I've been waiting long enough!
Is there a bugfix for this error now?

Re: Flashpro crashes after start engine, start a datalog!

Posted: Mon Jun 19, 2017 12:31 pm
by R-12914
Today i have tested it again with the Software 2.7.4.0 and Firmware 115, but the problem still exists!

Re: Flashpro crashes after start engine, start a datalog!

Posted: Wed Jun 21, 2017 10:33 am
by Hondata
Can you give a detailed method to reproduce this? We have tested and found no issue.

With datalogging when cranking the engine, if the voltage drops low enough that the FlashPro processor resets, then the datalog will stop. The FlashPro was not designed to cope with these low voltage situations, but generally will datalog when cranking.

Re: Flashpro crashes after start engine, start a datalog!

Posted: Wed Jun 21, 2017 11:36 am
by R-12914
Hondata wrote: Wed Jun 21, 2017 10:33 am Can you give a detailed method to reproduce this? We have tested and found no issue.

In this case, the problem exist (every time):


1. Plug Flashpro into the OBD2 Port.
2. Start engine.
3. The car is parked (without movement).
4. Start datalog (with the datalog button).
5. The datalog LED is flashing and a datalog ist starting, the Power-LED (shines) furthermore.
6. This condition is for a few seconds.
7. Both LEDs go off (as if the Flashpro crashes).
8. A short Datalog (incorrect) is saved on the Flashpro.


In this case, the problem does not exist (every time):


1. Plug Flashpro into the OBD2 Port.
2. Start engine.
3. The car is moved for about a minute.
4. Start datalog (with the datalog button).
5. The datalog LED is flashing and a datalog ist starting, the Power-LED (shines) furthermore.
6. This condition is until I finish the datalog (press the datalog button) or turn off the engine.
7. In this case, the Flashpro is stable (as was the case before).
8. A long (correct) Datalog is saved on the Flashpro.



Yet another problem:
If the Flashpro is plugged into the OBD2 port and i want to make a Datalog again at the next eninge start, it sometimes happens that the Flashpro does not respond to keypresses (as if it had frozen).

Then if i have to unplug the Flashpro and plug it in again, so it works fine.

This problem exists with several users, but is probably not related to the other problem I have described.

Re: Flashpro crashes after start engine, start a datalog!

Posted: Wed Jun 21, 2017 12:36 pm
by Hondata
Can you provide the calibration? Either here or to support@hondata.com. Also can you use the 'send support information to hondata' function with the FlashPro plugged into the vehicle.

Re: Flashpro crashes after start engine, start a datalog!

Posted: Wed Jun 21, 2017 12:43 pm
by R-12914
Hondata wrote: Wed Jun 21, 2017 12:36 pm Can you provide the calibration? Either here or to support@hondata.com. Also can you use the 'send support information to hondata' function with the FlashPro plugged into the vehicle.
Ok, now i have send you a email to support@hondata.com.
And i have made "send support information to hondata".

If you need more info, please let me know!

Re: Flashpro crashes after start engine, start a datalog!

Posted: Wed Jun 21, 2017 1:32 pm
by Hondata
Got everything; thank you.

Re: Flashpro crashes after start engine, start a datalog!

Posted: Thu Jun 22, 2017 1:37 pm
by Hondata
We've made a change for the next release. We expect that release to be tomorrow.

Re: Flashpro crashes after start engine, start a datalog!

Posted: Thu Jun 22, 2017 2:13 pm
by R-12914
Hondata wrote: Thu Jun 22, 2017 1:37 pm We've made a change for the next release. We expect that release to be tomorrow.
Nice, thank you!

Re: Flashpro crashes after start engine, start a datalog!

Posted: Fri Jun 23, 2017 2:28 pm
by R-12914