Page 1 of 1

RomEditor4 FTDI USB Fix

Posted: Thu Oct 30, 2008 9:51 am
by Hondata
RomEditor4 users need to run a utility to fix a problem with the USB drivers. For more information and update instructions, go here


Posted: Fri Nov 21, 2008 1:29 am
It stats that serial # 0171 and prior need this fix , so I got serial # 4398 so I dont need to fix anything with the drivers correct. ...I just want to double check

Posted: Fri Nov 21, 2008 8:29 am
by Hondata
I suspect that your serial number is not from a RomEditor4 cable.

Posted: Fri Nov 21, 2008 10:39 am
Opps , that was the serial # from my k-pro box. The rom4editor cable is the usb cable ? Sorry but I am trying to figure this out.

Posted: Fri Nov 21, 2008 12:02 pm
by Spunkster
If you have not purchased Romeditor 4 then this does not apply to you.

Posted: Fri Nov 21, 2008 12:22 pm
Spunkster wrote:If you have not purchased Romeditor 4 then this does not apply to you.
thanks , yeah I talked to my tuner and he told me that the romeditor4 was for the early hondata products like S300 and such. I just was like wth is romeditor 4 and had to make sure my dads laptop would be ok.

Posted: Tue Feb 24, 2009 8:31 am
Im trying to run the fix but I keep getting a red lettered message: "Could not find any FTDI devices"

My computer does not recognize the USB anymore as a hondata device. Thus I cannot save any files. Any hints for me guys?

edit: I wonder if my cable is bad? I get this message when I plug it in now. It worked perfeclty since 2007. (my serial cable # is 0013 lol)

"USB device not recognized. One of the USB devices attatched to this computer has malfunctioned, and windows does not recognize it. For assistance with this problem please click on this message. "

Im running windows vista (sucks I know) but have had zero issues until a few days ago. I tried uninstalling and reinstalling ROMeditor4 and the usb drivers. Still nothing.

Posted: Tue Feb 24, 2009 10:25 am
by Spunkster
What is the Romeditor 4 cable showing up as in the Windows device manager?

Posted: Tue Feb 24, 2009 12:12 pm
Its coming up as an "Unknown device"

Posted: Tue Feb 24, 2009 1:00 pm
by Spunkster
In the device manager if you right click on the "unknown device" and go to properties and update the drivier making sure you specify the location as the Romeditor 4 directory, what happens?

Posted: Tue Feb 24, 2009 1:50 pm
I get this message:

"The best driver is already in stalled for this device
windows has determined that driver software for this device is up to date."

When I step back and click the "driver details" button I get this message.

"No driver files are required or have been loaded for this device."

Posted: Tue Feb 24, 2009 1:56 pm
by Spunkster
Are you letting it search for the driver, or are you pointing it to the Romeditor 4 directory under program files?

Posted: Tue Feb 24, 2009 2:48 pm
Im directing it manually to program files/romeditor4

I have also tried uninstalling romeditor4 and reinstalling it and it still does the same thing.

Posted: Tue Feb 24, 2009 4:38 pm
by Spunkster
please call for an RMA #