k20z3 dc2 idle drop while rolling only when warmed up

K-Series Programmable ECU installation questions / support issues
Post Reply
Brian_dc2
Posts: 6
Joined: Sun Aug 04, 2019 5:18 pm

k20z3 dc2 idle drop while rolling only when warmed up

Post by Brian_dc2 » Sun Aug 04, 2019 5:35 pm

Hey guys, so the title says it all. ive been having this issue for some time and working on it on and off, confirmed and checked many things and also scrolled through many threads on the internet for similar issue but not quite the same problem as im having.

Here are some specs:
k20z3 Dc2 on kpro v3 tuned
motor is internally stock as is trans/clutch etc
rywire kswap harness, ktuned conversion harness
k tuned fuel system but stock injectors 255 pump
karcpets adapter plate with stock tb with new oem iacv and k tuned hall affect tps
hybrid intake, karcepts header oem type s o2, 3in ss mandrel bent exaust to a vibrant uqr
using the ktuned vss calibrator as well if that matters.

My issue is that when the vehicle is warmed up to 180 the idle will drop to about 500-650 range only when rolling, the second i come to a stop it shoots back up to the target idle perfectly, the car has absolutely no drive-ability issues or CELs present. I checked a lot of wiring for the o2, vss, tps everything is in order with no resistance issues, as well as the components themselves are new. i have oem coil packs and spark plugs new as well. At this point i am wondering if it has something to do with tuning. This issue did not make itself present until i had a tps and iacv issue where i ended up replacing both as the bearing in the iacv was unable to spin freely even with cleaning as well as the tps simply going bad. After replacing and calibrating everything was fine, this was earlier this year during colder weather so the problem had not shown itself.
one thing that bothers me is im unable to determine my a/f ratio even though i have my o2 setup with built in wideband oem on kpro, i have some photos i will attatch to this thread.
Attachments
aaaa.jpg
aaaa.jpg (15.96 KiB) Viewed 181 times
aaa.jpg
aaa.jpg (15.49 KiB) Viewed 181 times
aa.jpg
aa.jpg (18.95 KiB) Viewed 181 times
a.jpg
a.jpg (19.46 KiB) Viewed 181 times
built in wideband.jpg
built in wideband.jpg (77.55 KiB) Viewed 181 times

Brian_dc2
Posts: 6
Joined: Sun Aug 04, 2019 5:18 pm

Re: k20z3 dc2 idle drop while rolling only when warmed up

Post by Brian_dc2 » Sun Aug 04, 2019 5:35 pm

some more photos
Attachments
bb.jpg
bb.jpg (14.92 KiB) Viewed 180 times
b.jpg
b.jpg (16.57 KiB) Viewed 180 times
aaaaa.jpg
aaaaa.jpg (15.92 KiB) Viewed 180 times

User avatar
Spunkster
Site Admin
Posts: 17864
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: k20z3 dc2 idle drop while rolling only when warmed up

Post by Spunkster » Mon Aug 05, 2019 4:52 pm

You need to post your calibration as well as a datalog showing the problem. Screenshots do not show the whole picture.

Brian_dc2
Posts: 6
Joined: Sun Aug 04, 2019 5:18 pm

Re: k20z3 dc2 idle drop while rolling only when warmed up

Post by Brian_dc2 » Wed Aug 07, 2019 7:22 pm

my apologies, here ya go
Attachments
idle drop.kdl
(1.18 MiB) Downloaded 10 times
droppp.kdl
(1.48 MiB) Downloaded 7 times
hall effect tps range norm vss closed loop hondata.kal
(163.14 KiB) Downloaded 9 times

Brian_dc2
Posts: 6
Joined: Sun Aug 04, 2019 5:18 pm

Re: k20z3 dc2 idle drop while rolling only when warmed up

Post by Brian_dc2 » Mon Aug 12, 2019 4:38 pm

Spunkster wrote:
Mon Aug 05, 2019 4:52 pm
You need to post your calibration as well as a datalog showing the problem. Screenshots do not show the whole picture.
uploaded..
also yesterday when driving the vehicle i noticed when it was on the colder side of ambient air temp and water temp the rolling rpm would be raised slightly to around 1200 steadily. showing signs of the exact opposite as compared to reactions when warm

Post Reply