Dreaded P0341 no VTEC or VTC

K-Series Programmable ECU installation questions / support issues
Post Reply
Jdmboyef9
Posts: 1
Joined: Thu Jul 11, 2019 10:54 am

Dreaded P0341 no VTEC or VTC

Post by Jdmboyef9 » Thu Jul 11, 2019 11:17 am

Recently got my K24A TSX engine installed and it is throwing the P0341 cam position sensor code. We know the problem is likely a stretched timing chain as we already swapped the TCT for a new one. Timing marks on the cam gears were nearly perfect but the dowel holes were slightly off.
My question is Kmanager allows to disable this code (obviously not fixing the issue) and it locks the VTC not allowing adjustments (Perfectly understandable), however, will this still not allow the VTEC to engage? My tuner even tested the solenoid to verify it engaged by manually overriding it but with the laptop it would not cross into the high cam profile or activate at any rpm. All of the wiring is factory with no other codes or bad sensors. Will disabling code P0341 disable both VTC and VTEC or might I have another problem to troubleshoot?

User avatar
Spunkster
Site Admin
Posts: 17842
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: Dreaded P0341 no VTEC or VTC

Post by Spunkster » Thu Jul 11, 2019 1:16 pm

I'm not sure if it will also cause VTC and VTEC to stop working. I would start by fixing the issue and see if that resolves the other issues.

User avatar
Hondata
Site Admin
Posts: 8713
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: Dreaded P0341 no VTEC or VTC

Post by Hondata » Thu Jul 11, 2019 2:09 pm

Don't use the cam gear marking to check cam timing use the sensor wheels on the flywheel end of the head.
Hondata

Post Reply