Search found 9 matches

by Raidenreda
Wed Apr 29, 2020 12:20 pm
Forum: K-Pro / KManager
Topic: AEM 30-0300 Wideband Integration with Kpro v4
Replies: 19
Views: 824

Re: AEM 30-0300 Wideband Integration with Kpro v4

i actualy selected the 30-2310 because it was the perfect match readings between the kpro and the aem guage
by Raidenreda
Tue Nov 12, 2019 9:01 am
Forum: K-Pro Calibrations
Topic: K20a2 Pra ecu Street tuned Kal
Replies: 7
Views: 947

Re: K20a2 Pra ecu Street tuned Kal

The spark plugs are oem IFR7G-11KS im living in north Africa that s why there is no dyno or tuners over here and its the only K swap in the whole country.
by Raidenreda
Tue Nov 12, 2019 7:38 am
Forum: K-Pro Calibrations
Topic: K20a2 Pra ecu Street tuned Kal
Replies: 7
Views: 947

Re: K20a2 Pra ecu Street tuned Kal

Thank you for your reply
95 fuel is the best i can get here and my spark plugs are new and pre gapped didn't get you about the WOT system
by Raidenreda
Mon Nov 11, 2019 7:52 am
Forum: K-Pro Calibrations
Topic: K20a2 Pra ecu Street tuned Kal
Replies: 7
Views: 947

Re: K20a2 Pra ecu Street tuned Kal

Everything is in the link below my post
by Raidenreda
Sun Nov 10, 2019 12:04 pm
Forum: K-Pro Calibrations
Topic: K20a2 Pra ecu Street tuned Kal
Replies: 7
Views: 947

K20a2 Pra ecu Street tuned Kal

Hello everyone this my Kal street tuned on 95 pump gas my mods are skunk2 ultra manifold with IMG ktuned Cai and headers skunk2 3" exhaust and aem wideband in closed loop as primary sensor. Can anyone check it if its properly tuned and if there is still more to adjust to get the maximum performance....
by Raidenreda
Tue Jun 04, 2019 9:20 am
Forum: K-Pro / KManager
Topic: KPRO V4 running lean problem
Replies: 11
Views: 1846

Re: KPRO V4 running lean problem

Ok thank you apreciate your help
by Raidenreda
Mon Jun 03, 2019 4:52 pm
Forum: K-Pro / KManager
Topic: KPRO V4 running lean problem
Replies: 11
Views: 1846

Re: KPRO V4 running lean problem

Yes i tried it. It s normal to run lean at every startup for a few seconds(arround 17 to 18 afr) then goes to normal
by Raidenreda
Mon Jun 03, 2019 12:03 pm
Forum: K-Pro / KManager
Topic: KPRO V4 running lean problem
Replies: 11
Views: 1846

Re: KPRO V4 running lean problem

The closer one is the aem 30-2310 but i don't think it's the same what do you think ?
by Raidenreda
Mon Jun 03, 2019 8:40 am
Forum: K-Pro / KManager
Topic: KPRO V4 running lean problem
Replies: 11
Views: 1846

Re: KPRO V4 running lean problem

Hello sorry i know it's an old post but i had the same issue i have the aem xseries 30-0300 and i couldn t find it on kpro to run cloosed loop via analog input (my Ecu is a PRA kpro v4).
Thank you