Page 1 of 1

Gear on display

Posted: Wed May 01, 2019 12:34 pm
by autox19
I have an LS transmission, and I dont have anything from it going to the ecu. so I would expect it to not show anything in the gear selection on the display in Smanager. What I find is it switches 1-5 pretty randomly. sometimes staying "in a gear" for 5-6 seconds, sometimes a blip. Should this be of concern? I am not having any setting change with the gear selection.

Odie
Fiat X19 with B16

Re: Gear on display

Posted: Wed May 01, 2019 2:16 pm
by Spunkster
Do you have a working VSS?

Re: Gear on display

Posted: Wed May 01, 2019 2:29 pm
by autox19
Yup yup. Vss works perfectly.

Odie

Re: Gear on display

Posted: Wed May 01, 2019 2:42 pm
by Spunkster
Post your calibration as well as a Datalog showing the issue.

Re: Gear on display

Posted: Wed May 01, 2019 3:01 pm
by autox19
here ya go. this is NOT a tuned calibration. Just getting things going.


Odie

Re: Gear on display

Posted: Wed May 01, 2019 4:56 pm
by Spunkster
Make sure you have the correct gear ratios selected in the gear compensation tab.

Re: Gear on display

Posted: Wed May 01, 2019 5:07 pm
by autox19
Ok. But not sure what that would have to do with gear selection when there is nothing from the trans to the ecu.

Odie

Re: Gear on display

Posted: Wed May 01, 2019 5:12 pm
by autox19
Unless..... it takes the vss and the rpm going back through the gear table to figure out what gear it is in.

Very cool..i will try that when/if it stops raining. (Not a wet weather car)

Odie

Re: Gear on display

Posted: Sat May 04, 2019 6:05 am
by crluver123
autox19 wrote:
Wed May 01, 2019 5:12 pm
Unless..... it takes the vss and the rpm going back through the gear table to figure out what gear it is in.

Very cool..i will try that when/if it stops raining. (Not a wet weather car)

Odie
yes that is all the ecu uses to determine gear: VSS compared to rpm, using algorithms determined via the gear ratios and final drive ratio.