Bought a Used 08 is it flashed?

Questions / support for the K-Series ECU re-flash
Post Reply
Sweetdeal
Posts: 4
Joined: Sun Oct 31, 2010 5:17 am

Bought a Used 08 is it flashed?

Post by Sweetdeal » Sun Oct 31, 2010 5:42 am

Please excuse my ignorance and possibly obvious question i may ask, as i am new to the Honda tuning world. Had a tuned and modded mustang before so I am not completely retarded on the topics. But these Japaneses cars use completely different techniques.

So i just recently bought a used 2008, SI with mods already done. Injen CAI, Headers, and full 3" exhaust (no cats). The Ecu Cover has a Hondata sticker...But not sure if the flash is/has been done or not. I can still hear the VTEC Kick in at the stock 5800, but it feels like it has a lot more power prior to that. I also have a CEL codes from secondary o2 sensors. Is that going to hurt fuel mileage or cause issues?

I know a CEL due to O2 on a stock ECU would screw up your MPG but what about if it is re-flashed? Should I worry or Just buy some MIL eliminators? Thanks in advance for any help or advice!

ECU#
37820-rrb-a13
4744-141893.

User avatar
Hondata
Site Admin
Posts: 8776
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Post by Hondata » Mon Nov 01, 2010 10:07 am

We have not reflashed that ECU.
Hondata

Floppie
Posts: 71
Joined: Thu Mar 18, 2010 11:11 pm
Location: Philadelphia, PA
Contact:

Post by Floppie » Mon Nov 01, 2010 12:18 pm

If it has a Hondata sticker but the VTEC point is 5800 (and they don't have a reflash on record), check to see if it has a USB port. You might have yourself a Kpro.

User avatar
Spunkster
Site Admin
Posts: 18012
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Post by Spunkster » Mon Nov 01, 2010 12:22 pm

The K-Pro is not compatible with an 08 SI.

Sweetdeal
Posts: 4
Joined: Sun Oct 31, 2010 5:17 am

Post by Sweetdeal » Mon Nov 01, 2010 8:10 pm

Why would he put the sticker on it? Could it have been swaped with another?

Sweetdeal
Posts: 4
Joined: Sun Oct 31, 2010 5:17 am

Post by Sweetdeal » Sat Nov 06, 2010 6:24 am

so another lil tidbit we we noticed yesterday. When i took it to my buddies Honda shop where he works we hooked it up to the Honda Diagnostics computer,

It showed that Both the short term and long term A/F were running a little rich mostly likely due to the full exhaust and the rear O2 sensor causing a CEL.

So as he began looking at a few other things we notice the name on the ECU showed the typical "Honda and some serial numbers" but it also said (Diesel). Obviously it isn't a diesel ECU program because the car is running fine. Has anyone ever seen this? or have any explanation?

I am thinking i should just buy some MIL eliminators to help solve the Rear O2 issue CEL and it might correct the fact that it is running rich?

Post Reply